//ArrowChat Code

Upcoming Events for the Next 120 Day(s)

Results 1 to 4 of 4

Thread: New guy from Michigan here

  1. #1
    Join Date
    Aug 2018
    Location
    Michigan,USA
    --
    4

    New guy from Michigan here

    Hey guys recently picked up a 83 Yamaha trimoto 125 for 200 bucks. I got it going sort of. I cleaned the whole carb, drained old fuel and cleaned the tank, new spark plug, do need a new air filter, though I'm having trouble finding one, clead reed valves.Now it'll only start and stay running at full throttle. Once I let off it will sputter out and die, then it won't start for about 5-10 minutes. I'm out of ideas, any help is appreciated.

    Sent from my SM-J727U using Tapatalk

  2. #2
    Join Date
    Aug 2018
    Location
    Michigan,USA
    --
    4
    Sent from my SM-J727U using Tapatalk[/QUOTE]Repost, first one was in wrong Place

    Sent from my SM-J727U using Tapatalk

  3. #3
    Join Date
    Apr 2014
    Location
    Edmond, KS
    --
    1,313
    If your air filter is missing or has part of it missing, you are probably running lean and this could be your problem. I wouldn't run it any more without an air filter. After you replace it, then you can continue on with your testing. Running lean will cause engine damage after a while.

  4. #4
    Join Date
    Aug 2018
    Location
    Michigan,USA
    --
    4
    Got a new air filter and the problem is still occurring. Any ideas as to where I should start looking

    Sent from my SM-J727U using Tapatalk

//ArrowChat Integreation Code //