//ArrowChat Code

Upcoming Events for the Next 120 Day(s)

Results 1 to 7 of 7

Thread: 85 250sx no spark

  1. #1
    Join Date
    Feb 2015
    Location
    new york
    --
    84

    85 250sx no spark

    hi.i have no spark and no neutral light when i turn on the key switch.the neutral light does come on when i hit the start button but no spark.any help would be great.thank you

  2. #2
    gimmeamidget is offline At The Back Of The Pack Arm chair racerAt the back of the pack
    Join Date
    Jun 2014
    Location
    utah
    --
    359
    Sounds like wiring is wrong. The neutral light should come on when you turn key on not when you push start button.

  3. #3
    Join Date
    Apr 2019
    Location
    South Dakota
    --
    89
    Quote Originally Posted by gimmeamidget View Post
    Sounds like wiring is wrong. The neutral light should come on when you turn key on not when you push start button.
    I would agree. Find a wiring diagram and then start tracing wire routing. The neutral light works by grounding, when the transmission is in neutral the light circuit is grounded, so the light turns on. I bet that you have some grounding issues. When you push the start button whatever wires are messed up are probably grounding and turn the light on. This might explain you spark issues. If neutral safety is not working properly, you won't have any spark. If anything, to get it running, try putting a wire from the neutral safety switch directly to a secure ground, however, I would recommend fixing it correctly.
    Currently owned:
    1987 250es
    1987 250es (running, but needs more work to ride)
    1985 250es (parts)- sold!
    1985 250es (parts)
    1983 200e (parts)
    1980 CT70
    1995 Foreman 400
    1971 AT1 125- Sold!
    196? Suzuki B100p- Sold!
    1976 KZ400D (it is coming together)

  4. #4
    Join Date
    Apr 2012
    Location
    MI, USA
    --
    3,798
    Interesting issue. Here's the 85 250sx wire diagram.

    Wire of interest is the Light Green/Red wire, it goes to the neutral safety switch (grounds when in neutral), and the other ends of the wire goes to the CDI (neutral safety detection), and the neutral light bulb through a diode (probably something relating to the CDI's side of things). The neutral and reverse lights get power from the power supply wire (black), same wire powers the headlights and such through the light switch.

    I looked over the wire diagram for a while, I don't really see how someone could swap a couple wires to get this effect. Guessing something more major is going on, like some harness hacking, or someone trying to bypass something. Here's a list of wires and colors that relate to the electric start system and the neutral safety.

    Light Green/Red - Neutral Safety
    Green/Red - Same as neutral safety, but comes out at the starter solenoid as normal green
    Yellow/Red - power wire from start button to starter solenoid
    Black - Power source for lights, electric start, etc
    Green - Frame/Engine Ground
    Gray - Not directly related, but this is the reverse safety switch wire, it's only job is to light up the reverse light, nothing more.

    All connectors should have the same color wires on both sides. I'd pay extra attention to Red/Green, it's the most common color blindness. Just found out my cousin has a moderate case of Red/Green color blindness, he never knew, he was in a wreck which caused brain sheer, so not sure if it's from that or he had it since birth. Only way I suspected it was in a dark lit store, he couldn't tell a red vs green pack of cigs apart. Also he mixed up the wiring on his 250sx, got no spark because he had the wiring connected up wrong.


  5. #5
    Join Date
    Feb 2015
    Location
    new york
    --
    84
    thanks for the help.got it figured out.was just two wires in the wrong place.switched them got neutral light and spark now.thanks again.

  6. #6
    Join Date
    Apr 2012
    Location
    MI, USA
    --
    3,798
    Any idea which two wires were swapped? Just for a good reference if someone else comes across the same situation.

  7. #7
    Join Date
    Feb 2015
    Location
    new york
    --
    84
    yes.there is a solid black and a black with white stripe that i had wrong.i had just over looked it.thanks again for your help.

//ArrowChat Integreation Code //